Mar 21, 2009

Install Windows XP in Compaq Presario CQ40-401AU Notebook


Compaq Presario CQ40-401AU is design for windows vista. Installing windows XP driectly using original windows XP CD will result in Blue Screen Error or " No hdd was found".

There is a famous trick to solve this problems which know as slipstream guiide to install windows XP. Slipstream process is not too difficult but for this model which use AMD sata drivers it can be a little bit tricky.

You can read how to slipstream guide here, something worth to mention is:
1. Make sure to use right sata drivers.
2. If you are about to repeat the process, delete all folders and create new folder.
3. If you failed 2 - 3 times, that normal.
4. Windows XP SP2 is preferable.

TUTORIAL LINK: Slipstream Guide to Install windows XP

80 comments:

  1. hi,thx for the link,i did try what u suggest,but instead ,i use a floppy disk,after i dl n extract the file,i copy it to a diskette,then i pres f6 for 3rd party driver,this is what i got when i choose x86. file\x86\ahcix86.sys caused an unexpected error (18) at line 2113 in d:\xpsprtm\base\boot\setup\oemdisk.c. help plz..thx

    ReplyDelete
  2. First make sure structure of the floppy needs to be this way:

    X86 (folder with the ahcix86.cat, ahcix86.inf, and ahcix86.sys files in it)
    AHCIX86 (file)
    TXTSETUP.OEM (file)

    All 3 should be listed this way off the root of the floppy.
    Report back after you confirm it

    ReplyDelete
  3. And one more thing i suggest instead of using floppy try to slipstream it using nLite,

    ReplyDelete
  4. thx done.my mistake.hehe.now another probs.they r 2 pci device.i believe 1 is audio while another is hdmi driver.but i couldnt found it.can help?thxxx

    ReplyDelete
  5. First i need to know did your sound working or not, if working thn you can just ignore it, and if u are using windows use SP2 and try this driver:

    Microsoft UAA HDMI Audio Class Drive
    Download here

    ReplyDelete
  6. ok the thing is like this,i already install the uaa b4 this(dl from hp website),then system detect 2 audio high definition device,i try installed many version from hp website n 3rd party but stil not working,other basic driver is done

    ReplyDelete
  7. thx for the link.done =) n thx again for ur frenly help n guide

    ReplyDelete
  8. hai...obiously i need ur help...a new laptop CQ40-401AU is install with win vista i need to install win xp can u help me step by step??using CD not floppy cz i dun have external floppy..THANX..

    ReplyDelete
  9. OK, here what you need to do, first if you dont have floppy, you can use CD, you need to create a new bootable CD (like windows XP CD. Thi s process called slipstream>

    Material you need.

    1. A new CD or CDs

    2 Nlite software
    Download here3. SATA AHCI DRIVER
    Download here: http://www.mediafire.com/?azwrxx0xkrpthen if you already have all of the material, follow step describe here:

    http://maxeasyguide.blogspot.com/2008/04/preparations-for-winxp-installation-cd.htmlif you still not understand how to slipstream, you can search using google, just search for the "slipstream" keyword, there are many guide how to slipstream.

    i not plan to write about it since the link for the guide id given is already describe in details, any terms that you don't understand you ca come back and leave your comments here

    ReplyDelete
  10. thx.. i download ready ..but...sata achi driver is corrupted yar...help me.. :(

    ReplyDelete
  11. Are both of the links given Broken, if corrupted you should download it again, if you downloaded from media fire and broken, download from gigabyte. here the links again:

    http://www.gigabyte.com.tw/Support/Motherboard/Driver_DownloadFile.aspx?FileType=Driver&FileID=3676.............
    .............................

    remember, i give you the link for the tutorial, don't download sata ahci from the site, download that the one give above. if you download it and corrupt again leave ur comment and i will upload once more. Please make sure you follow the guide given properly, one more thing i need to know the exact eror phrase you got during the installation.

    ReplyDelete
  12. Can i use those driver for my CQ40-401TU not AU?

    ReplyDelete
  13. No because AU use AMD while TU use Intel chipset. So the driver given above for AMD only, you can use this driver for your Compaq CQ40-401TU
    http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProductID=2991&DwnldID=16759&strOSs=All&OSFullName=All%20Operating%20Systems&lang=engthis is my suggestion but i think it will work, inform back for the progress

    ReplyDelete
  14. Please help me Mr. Black-x
    i got a message "the file ahcix64.sys is corrupted" in windows setup. I used SATA driver from mediafire.
    With nlite i inserted single driver, ahcix64.inf, textmode,then i choose AMD SATA AHCI Controller x-64 platform.
    Thanks

    ReplyDelete
  15. the file ahcix64.sys is corrupted cause by several things,

    1. Use latest windows XP patch which is service pack 2 which you can get from microsoft site.

    2. You only select AHCI64 for windows 32 bit is might cuae the error.

    I encountered the same problems like yours, but i fix it by following the guide here:

    http://www.howtogeek.com/howto/windows/resolving-setup-did-not-find-any-hard-disk-drives-during-windows-xp-installation/The main thing you need to notice is if you using windows XP make sure it is SP2, then make sure to select the proper driver. windows 32bit use AHCI86 and windows xp 64 use AHCI64. Hope this help, inform back the progress and thanks for the feedback=)

    ReplyDelete
  16. Thanks for the reply mr black.
    You're right, i have to select x86 for my 32bit windows XP SP2.But now i have another problem. I failed to install ATI graphic driver. It said something like "unable to find compatible hardware or operating system. Setup will exit now"

    Filename:9-4_xp32_dd_ccc_wdm_enu.exe
    dotnetfx already installed.

    ReplyDelete
  17. in trying...will gv u d feedback later..thanks...Mr.Black-x

    ReplyDelete
  18. Your graphics is ATI Radeon HD 3200 Graphics:

    I have two options for you, first download the this driver from softpedia which also suitable for ATI Radeon HD 3200/3450/3650. size: 114mb

    HP ATI Radeon HD 3200/3450/3650 Graphics Driver 8.533.1.0 Rev.Aor use ati catalyst:
    http://game.amd.com/us-en/drivers_catalyst.aspx?p=xp/integrated-xp or ati mobility which i really recomemded: read the whole instruction at the link given. It should work:
    Driver heavenOnce again even you mentioned already installed netframework but i would like to remind again, install the netframework before graphics.
    Good luck

    ReplyDelete
  19. i got a message "the file ahcix64.sys is corrupted" again...

    ReplyDelete
  20. wut shud i do...??maybe my xp files??

    ReplyDelete
  21. I already succesfully installed xp in CQ40-401au:

    i suggest try other xp cd, and the sata ahci i used was from the gigabyte:

    http://www.gigabyte.com.tw/Support/Motherboard/Driver_DownloadFile.aspx?FileType=Driver&FileID=3676just follow the slipstream driver noramlly.

    ReplyDelete
  22. Hye guys,

    I'm using Compaq Presario CQ40-406au (AMD). I need to downgred my OS from Vista to XP and everybody in here really helping me. Thanks. I just want to share my problem so maybe next time if there is anybody else getting same problem as mine can solve it easily.

    First time i create bootable XP using nlite it's failed. Error "...ahcix64 file corrupted..". My mistake here is selecting x64 from my sata driver. I'm suppose to select x86. But after i realize my mistake, i tried to create another bootable cd and selecting x86 but still the same error appeared. After wasting 5 of my dvd, i realize that i'm not suppose to use the same folder of win xp that i copied to my harddrive because nlite will copy and change all the setting effecting the original file of windows xp that i copied before.

    Use the fresh file of winxp if u want to create another bootable cd. I already installed Xp in my compaq cq40-40au and i really want to share this with everybody. :)

    ReplyDelete
  23. Thats great itapac crew, thanks so much for shraing, iwill publish your comment as a post and givr the credits for u, thanks agains

    ReplyDelete
  24. Mr.black x, i try to using the sata raid driver to format windows xp at compaq presario cq40-401au (new buy)
    then i select AMD Sata ahci controller-x86 platform after press f6. it can successful to windows making partition, one problems it is need "amd sata ahci controller driver diskette" then it was cannot copy system files from windows XP sp2 disc.
    Please help me. Thank you black x

    ReplyDelete
  25. IT students plz infoem me, Did you use a original windows XP cd or you already create a new windows xp using slipstreaming method to format you laptop?

    ReplyDelete
  26. hi can i ask if whtr would there be any difference if i were to use the original winxp SP1 cd? i have tried to do slipstream win XP SP1 and it doesnt seem to work.

    pls advice..

    ReplyDelete
  27. if u want to install Windows Xp in Compaq CQ40-401au with the original cd, during the process it will not detect you hard disk, because it need sata drivers. So slipstreaming use to add those sata AHCI driver into your original windows XP cd. Most of the drivers nowadays build for windows XP SP2, you can upgrade your original SP1 into SP2 y.

    1.Download SP2 patch from microsoft site(free).
    2.Run the slipstreaming process by adding patch(normally you just integrate the drivers).
    3. I want to ask if you really understand how to slipstream or you just don eally undesand how to perform it and create a new bootable cd.

    For your information there are two types of windows XP tha is 32bits and 64bits. 32bits use AHCI86 and 64Bits use AHCI64.
    if you need more details please reply and i will describe more details.

    ReplyDelete
  28. managed to install xp using the floppy method.. lucky to still have the old floppy and then some ide-usb converter to do the work..

    anyway having trouble installing the video drivers. cant seems to get the right one on.. all other drivers installed with no problem..

    any advice on the video drivers?

    ReplyDelete
  29. Amelia:

    Install .Net Framework before others:
    http://tinyurl.com/758p8

    ATI Radeon HD 3200 Graphics/Video Driver
    here:
    http://game.amd.com/us-en/drivers_catalyst.aspx?p=xp/integrated-xp

    ReplyDelete
  30. Mr.black x, i have my xp and amd sata driver diskette, but ican't instal xp for my CQ40-401AU.
    i select AMD Sata ahci controller-x86 platform after press f6. it can successful to windows making partition, one problems it is need "amd sata ahci controller driver diskette"
    what should i do???

    ReplyDelete
  31. Mr. black-x,can u upload ur cd xp that had integrated with sata achi driver for compaq cq40-401au?plz...i had try my own for xp sp2 and xp sp3 and follow what u said..but both were fail and always said like "the file ahcix64.sys could not be found" and other one like "the file ahcix64.sys had been corrupted"..i had waste 5 cds doing such thing like diz..i don't like vista bcoz of its compatibility..plz..i hope u can upload via mediafire links..thx..

    ReplyDelete
  32. help me Mr. Black-x,
    can u print screen your slipstream amd using n-lite for installing winXP to compaq cq40-401au?
    the link that u give is about slipstream intel,not amd..
    i hope u can show me your ways slipstream amd step by step by using n-lite..plz...thx.

    ReplyDelete
  33. hai...im using cq40-401au..
    i sucessfully install xp sp2 wit d insruction given(thamks a lot)but i cannot instal net.frame..
    pleaze some one help me

    ReplyDelete
  34. i can upload via mediafire and inform you later, now im using internet at my workplace and i dont have much time(afraid that my boss notice), my internet connection at my area broke down for anout a weeks, you can leave your email and ill inform you when i upload it, about the diskete im not familiar installing with diskete, but try to read the first comments about the arragement of the files,
    First make sure structure of the floppy needs to be this way:

    X86 (folder with the ahcix86.cat, ahcix86.inf, and ahcix86.sys files in it)
    AHCIX86 (file)
    TXTSETUP.OEM (file)
    All 3 should be listed this way off the root of the floppy.

    Regarding failed to install netframework may cause from several things, just search with google with keyword "cannot install netframework" (i think i already knew the solution but i forgot)

    p/s: i will replied with details when the internet connection at my place fixed.

    ReplyDelete
  35. yes..i already make my laptop tip top thank you to all. just want to share ..if you have a problem just ask me k.

    ReplyDelete
  36. thank to all that give some idea to solve problem to install xp in compaqpresario cq40. i just already make a perffect installation of my laptop..i f you have a problem just ask me ok. i can help you if i can

    ReplyDelete
  37. hi mr black-x and royzam i bought cq40 3101au and im having a hard time sliptreaming. Im using nlite and followed the guide but my problem is it takes too long to burn the whole thing, about 17 hours, I have wasted 5 dvds already. I also tried making an iso image and its the same thing 17 freaking hours... is this normal or am I doing something wrong. TIA

    ReplyDelete
  38. Hi Black-x,

    Thank you for the great posts.
    It really helps me installing Win XP on CQ40-401AU.

    Hi Itapa Crew,

    Thank you for sharing your experience's. I did the same mistake of not copying a fresh copy of the win XP files from the cd after burning the image of failed attempts.

    ReplyDelete
  39. I have manage to install XP on my Compaq Presario CQ40-401AU Notebook PC. but my wireless lan just don work. anyone can help?

    ReplyDelete
  40. About failed and wased about 5 dvd, try to slipstream to make iso and burn it using nero, when you failed using slipstreaming process, make sure not to burn the same project, create new project, a new folder and at new partition, if you think you have problems with burner you could slipstream using another computer.
    About the wireless driver, i think the driver given will work, try to reinstall the driver, and inform me later, any other comments to help welcome, and if you like to post and be a an author to this blog, leave ur email, i still have problems with my wireless provider, and could not collect much resources as before, anyway i will keep update and reply your comments,=)
    (p/s: royzam, thanks=))

    ReplyDelete
  41. Dear Black-x,

    pls help me. I need AMD Chipset driver for ur Presario CQ40-401AU.


    Thx,

    ReplyDelete
  42. Mr black-x,

    Im the wasted 5 dvd guy, it turns out that the sata driver I downloaded was broken causing it to have some writing problem. Anyway, I solved the problem by downloading to another source.
    I managed to install xp and most of the drivers, however, Im really having trouble in installing the last 2 drivers

    1.Realtek RTL8102E Family PCI-E Fast Ethernet NIC from http://tinyurl.com/4ssd97

    2.HDMI Audio from http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PFid=24&Level=4&Conn=3&DownTypeID=3

    I'll be honest with number 1, I really dont know how to download the driver there so searched elsewhere, I think Im using the wrong driver. Pls guide me on how to go about it.
    I was able to successfully download number 2 though, but I cant seem to install it, Pls help.
    TIA

    ReplyDelete
  43. i will give another link and guide but i hope you can wait until this weekend,(about on saturday or sunday), plz check this post this weekend, if you want to be notify via email you can subscribe or leave ur email, thank=)
    (my internet services still broke down, im at my working place now, hiding,lol)=)

    ReplyDelete
  44. Blee_07:
    are u already installed all the driver listed here: http://laptop-driver.blogspot.com/2009/03/compaq-cq40-401au-xp-drivers.html if not try to install all of the driver first and inform the progress.(report back if any of driver missing)

    ReplyDelete
  45. 1.Realtek RTL8102E Family PCI-E Fast Ethernet NIC from http://tinyurl.com/4ssd97

    for this driver there are many driver available so download the follwing driver:
    WinXP (WinServer 2003) Driver ; and
    Auto installation program (Support WinXP64/WinXP/Win2K)(Submission ID:1329619). press the GO button to start download

    2.HDMI Audio from http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PFid=24&Level=4&Conn=3&DownTypeID=3
    for number two, unsuccesful may cause by incomplete download which mean the download are finish but the packets broken, you need to redownload and reinstall, and make sure the size of the file equal to the size given by the website. If still having problems reply back.

    ReplyDelete
  46. help me mr. black-x,

    the link that u give about slipstream intel..i have dwnload AMD SATA AHCI Controller Driver from http://www.gigabyte.com.tw/Support/Motherboard/Driver_DownloadFile.aspx?FileType=Driver&FileID=3676

    after that ,i extract it to my desktop n it show it's folder.
    inside that folder,i got files txtsetup.oem,readme,ahcix86,ahcix64 n 2 folders of x86 n x64..what should i do after this??

    i have opened folder x86 n slipstream using n-lite by using your instructions.when using n-lite i have
    tried insert single driver n browse on my desktop to get file.inf..i select folder x86 n found ahcix86.so i opened it..

    after that it shows amd ahci compatible raid controller-x64 platform n amd ahci cmpatible raid controller-x86 platform..which one should i choose ???

    i have try n error both options but still show a message "the file ahcix64.sys is corrupted" n another one "the file ahcix64.sys can't be found"..

    help me please..........

    ReplyDelete
  47. if the error is AHCI X64 means there are mistakes during the slipstream, u must choose X86 for normal windows Xp 32-bit(i think u are using 32 bit), when create a folder for windows XP files, it will copy all of the files from cd, but when the first time you slipstream was not successful, make another folder in another partiton and do not use the same folder,
    create a new folder in D the run the slipstream process, use single driver, select AHCIX86, the burn the CD

    ReplyDelete
  48. thanx bro!!such a good guide for me..

    ReplyDelete
  49. i need amd chipset driver for cq40-401au

    ReplyDelete
  50. Hi, Mr. BlackX,
    I bought COMPAQ CQ40-317TU, with FREE DOS and tried to install XP( I have Original XP) But I could not succeed and A BLUE screen was appearing at the moment windows was about to start for installation showing some binary e-ooooo7B any way I tried Vista and it got installed, I have USB Floppy Drive and I tried F6 Key with SATA drivers for AHCI9 but I could not succeed as the same blue screen appears, I read in the forums about slipstreaming with Nlite but I was not able to install finally went to dealer and he installed only XP without Drivers
    Now I am having problem with sound Driver and I followed Blogspot forum of SAYSPRASAD driver installed but doesnot start at the startup iinstead I have to go in device manager and disable and enable it. please help me for the driver sothat I can have the XP tone at the start up only. Itried many IDT drivers but none helped me.
    Thanx

    ReplyDelete
  51. Thanks Mr Black for your guidance. I've formatted my friend's CQ40-401AU to Win XP Sp2 successfully. Now looking for hardware drivers... thanks again.

    ReplyDelete
  52. i cannot do well in my compaq-401-au

    y? i already try to fit with ahcix86 or ahcix64, my winxp is service pack 3. it is the version is too high? hv to use service pack 2 or original version??

    thank you black-x

    ReplyDelete
  53. yes, try to use sp2 and do not repeat the method in the same folder, delete the old folder and create new one to repeat the process from the begining, you can get sp2 pack from microsoft or softpedia website

    ReplyDelete
  54. Hey guys. I'm new to this post I manage to install xp with all the recomendations, but after formating the disk and starts copying the files it gives me an error that could not copy the achix86.inf and also a ahcix86.o something. It manages to copy the ahcix86.sys, and installs XP, but after its finihes it looks like is going to work then it just reboots everytime. My laptop is a HP Pavilion dv-71132nr. Thanks for your help.

    ReplyDelete
  55. try to patch your laptop with SP2 patch and redownload the sata driver u use, try to repeat the slipstream again and you put multiple sata driver during the slipstream process

    ReplyDelete
  56. WOW. I finally made it. I was able P Pavilion dv7-1132nr after2 weeks of trying. Of all the reasearche I did this was the most helpful ever. I used the http://www.gigabyte.com.tw/Support/Motherboard/Driver_DownloadFile.aspx?FileType=Driver&FileID=3676 link and slipstream the ahcix86 SATA controller. I used an Windows XP HOME SP2 and nLite. Thansk for your help. Now my next task is my Sony Vaio VGN-FW340J.

    ReplyDelete
  57. thanks for the info, i need to know the link to get the sata driver you download so i can share it here

    ReplyDelete
  58. hi, i done and success to do the bootble CD + sata driver. my problem is after the 1st step done with copying file to hard-drive windows restart, just after win logo appear and the after a few second some error appear that cannot catch the whole text but end with "API" and the my notebook just SHUT DOWN. huh!~ even no say BYE BYE just shut down. can help me with this pls

    ReplyDelete
  59. hi, it happened to me once, and i repeated slipstream method and success, just delete all old file that you use to perform the slipstream and repeat the slipstream process using new folder

    ReplyDelete
  60. thaks dear Black-x, well bro i did all what ppl hav posted here. also reseting my cmos. and did reformat all my drive. this is might be bad to me to tell that i was hp technician before and at time the CQ40 no longer exist yet. i hav no idea now.. i did all what i knw and useless. now bro i try to do again the slipstream and also uninstall everythin might confic the DLL. and if after this i stil facing the same probs i hav to dare to go to hp serive centre and and thats so embarassng,. :(((

    ReplyDelete
  61. ok guys i done succesfully insall xp32bit. if facing same problem with me. prepare this. clean up the mess cd dvd every thing and take only FDD and the raid driver use the sp1 home if ur harddrive corrupted. and dont repair installation do install in antoher dir on it wil going succesful witout any error. one thing that i wan to tell u here, hp wasting their money to employ the chat online tecnician team. ptuik!!

    ReplyDelete
  62. Hi again, thansk for your info, anyway i alawys recomend user to use win XP xp and attach along the slipstream process, but here u prove sp1 works too, so u r on Hp technician, hope theres lot more you can share with us here, thanks again.

    ReplyDelete
  63. hi black-x , hi also to all!.

    CQ40-401AX setup problem shut down suddenly during setup. my tips to solve is.
    if the whole tips in world wer not work, do this way. prepare this
    1 windows xp sp1.
    2 Floppy drive.

    insert the cd and boot. hit F6 and install sata with winxp x86. u shoud pass BSOD error. change the installathin dir to any ( \windows\sp1\ or as whatever u like. to make sure no rewrite/repalace file will happen.

    u should success to install windows XP completely so after done. NOW can choose what ever version of XP u want it would be OKAY.

    some useful link ;
    https://www.blogger.com/comment.g?blogID=7456725692752621671&postID=4578474567839716565&page=1

    and

    http://forums11.itrc.hp.com/service/forums/bizsupport/questionanswer.do?threadId=1342185

    Thanks also to bro black-x and all here for sharing ur exp and tips bye.

    ReplyDelete
  64. This comment has been removed by the author.

    ReplyDelete
  65. Dear Black-x, I'm completed the install of XP on my CQ40-401AU via the slipstream disc, and installed all the other drivers, EXCEPT the audio driver... I've installed all the driver that you linked here but none worked... What should I do now?

    ReplyDelete
  66. hi Burney,
    For Your audio i recomended:
    download and install this first: ftp://ftp.hp.com/pub/softpaq/sp33501-34000/sp33867.exe
    reboot.
    then:
    download and install:http://www.mediafire.com/?vynu6uq4yzv and then ftp://ftp.hp.com/pub/softpaq/sp39501-40000/sp39545.exe


    here links for all your drivers with instuction, http://laptop-driver.blogspot.com/2009/03/compaq-cq40-401au-xp-drivers.html, i already updated the drivers link and the drivers version.

    another thing is i would like to thank you so much because i forgot to update the link for the audio driver (which the prior driver is the wrong driver). Your comments remind me to update it. Now all UPDATE..

    ReplyDelete
  67. Bro Black-x..

    Thankssssssssss... a lottttt...

    I really mean it

    ReplyDelete
  68. Cool article as for me. I'd like to read more concerning this topic. The only thing it would also be great to see on this blog is some photos of any gizmos.
    Jeff Stepman
    Cell jammer

    ReplyDelete
  69. Hello, Mr Black. Does the method (i mean Nlite) works with WinXP SP3? Because when I am trying to install XP, "ahcix64.sys file is not found" message comes up. thanks.

    ReplyDelete
  70. Normally it works but from many discusion and experiment, XP original or XP SP2 work best. AHCIx64 not found error normally occur to AMD model, which in step 8, notice that there are difference between AMD model and Intel model.

    ReplyDelete
  71. thanks bro nice work

    anuj
    http://winservers.co.in

    ReplyDelete
  72. Where can i find intel drivers, for my compaq presario cq56

    ReplyDelete
  73. I'm trying to slipstream also but i was using sp3 and the amd drivers. but now since that doesn't work i want to try the intel chipset drivers for that model and win xp sp2. thnks in advance

    ReplyDelete
  74. Hello all....I use a Compaq Presario CQ56 219 WM and I am dying to install windows xp on my system.. Please could you give me the name or the download link to the correct SATA driver for my laptop??

    ReplyDelete
  75. hai.laptop sy compaq presario cq40-401au.masaalahnya ialah. on laptop je screen blank.tak ada apa apa. LED di caplock dan numlock je yang berkelip.apa sebabnya.terima kasih.

    ReplyDelete