Nov 11, 2009

Installing Sound in Compaq CQ Series




Compaq Presario CQ series here including CQ40, CQ35 and CQ45. This method also applicable to other model which use IDT audio drivers. For other CQ model which use Conextant audio the patch installation and method is similar, the difference is you need to locate conextant audio drivers.
Last update: June 14 2013

PATCH INSTALLATION

If you already install ms-uaa you may skip this step.
 Before proceed with audio Installation you need to install Microsoft Universal Audio Architecture first. Below is the patch you needed.

Microsoft Universal Audio Architecture (MS-UAA)

Windows XP, XP SP2:  Knowledge Base 888111 (KB888111)
Download 

Windows XP SP3:Knowledge Base 835221 (KB835221)
 Download  (KB835221)

This downloads also available in Microsoft website, you just need to search the KB888111..etc.


DOWNLOAD AND INSTALL: IDT AUDIO DRIVERS

I provide few driver version here which reported work in most CQ40. The trick is simple, you just need to get your original vista drivers first. Here is the recommended and tested driver version.

SP39671.exe: Download - recommended (original xp driver for IDT)
SP41693.exe: Download 
SP45100.exe: Download
SP41616.exe: Download
 
Now Install the driver you selected from the list above or your original vista drivers. (do not restart) If the installation successful with no error, try any audio file for confirmation. If it resulting in error, or no sound after successful installation proceed with next step.

MANUALLY INSTALL DRIVER

This manual installation is also know as "have disk method".

1.First open device manager by click start and select run type "devmgmt.msc" as shown in the pictures below.



2.Below you will see there are many drivers with yellow, select the Audio with the yellow mark, right click on it and select update driver.



3. Harware update wizard screen will appear, select no to connect, next


4.Select Install from list specific location, next


5. select dont searh i will choose the driver to install, next

6.then select all drivers on the next screen then make sure you uncheck the "show compatible drivers" box, select have disk

7. then select browse:


8. Then browse to the directory c:\swsetup


9. Ok in this step i will show for SP39671 audio. So after open the swsetup folder select the SP36971 Folder. If you use other audio make sure to select the folder name similar to yours example: sp45100.




10. After open the SP39671, there 3 folder and select the wdm folder. For other audio driver maybe you will have the similar folder or different, Important to remember we a re looking for files ended with INF extension. Here for SP39671, after open the folder slect WDM folder and Select WInXP folder




11. Then select the STHDA.INF (STHDA64.INF is for 64 bit) anyway press OK . Ignore if XP Complaint. then try to play some music (suggested simple mp3, no rmvb, flv or other player that require codec).
INF file may have different name if you are using different driver version
In case the audio driver you have and i gave earlier didn,t work leave your comments and i will assist you for further instructions.


HDMI and NO SOUND AFTER RESTART

Some model will have issue with HDMI. To know either you have this issue or not, Simply after driver installation above a "new hardware found" windows appear. Download this driver first:
SP39545.exe

Now install this this driver first (do not close a new hardware found windows), after finish install, get back to the "a new hardware found windows" follow the audio installation we did earlier until we get the inf file.

In case the Audio Disappear After restart follow the Guide here:

AUDIO DISAPPAER AFTER RESTART: PART 1
AUDIO DISAPPAER AFTER RESTART: PART 2

37 comments:

  1. HELLO SIR
    i have done exactly all the steps given...but still my audio has not got installed...so plzzzzzzzzzzzzzz help me

    ReplyDelete
  2. HELLO SIR
    i have done exactly all the steps given...but still my audio has not got installed...so plzzzzzzzzzzzzzz help me

    ReplyDelete
  3. What is Your model? be specific

    ReplyDelete
  4. compaq presario cq40-327tu.how to install audio for this

    ReplyDelete
  5. Ok, open device manager (click start - run - type DEVMGMT.MSC.
    look for audio with yellow, right click select properties, select details and on the dropdown menu select hardware ID.

    Hightlight it and press CTRL + C to copy it and paste it here.

    ReplyDelete
  6. sir,i need your help...
    i've done all the steps..
    but my sound still mute...
    this is my laptop>> compaq presario CQ40-502AU,windows 7 32-bit

    ReplyDelete
  7. For qindows 7 nor,normally sound automatically install, try install the driver below.

    1. AUDIO
    IDT - High Definition Audio Codecs
    Download SP45211

    2. If not work i need to know is there small speaker(audio) icon at your taskbar(bottom right), if yes, can you enable it(unchecked the mute).

    report back the progress

    ReplyDelete
  8. Mr Black, i've try all the step that you suggest, but my audio on compaq CQ41-110AU still doesn't want to work.
    Could you please help me.
    FYI, I install xpsp3, and in device manager i have two "audio device on high definition audio bus".
    Could you please advice me.

    ReplyDelete
  9. Ok on the device manager right click and select properties, a windows will open, select DETAILS tab, and you will see a dropdown menu, select harware ID on the dropdown menu list, and copy it (press CTRL + C) and paste it here.

    ReplyDelete
  10. sir,
    im using CQ40-301tu model and i recently installed xp.i still hve the audio driver problem ..i installed it in the procedure what u said..but finally im getting an error message saying "the audio device cannot be started (code10)"

    ReplyDelete
  11. "Black-x said...

    Ok on the device manager right click and select properties, a windows will open, select DETAILS tab, and you will see a dropdown menu, select harware ID on the dropdown menu list, and copy it (press CTRL + C) and paste it here."


    information of compaq cq41-110au...


    hardware id=

    HDAUDIO\FUNC_01&VEN_1002&DEV_791A&SUBSYS_00791A00&REV_1000
    HDAUDIO\FUNC_01&VEN_111D&DEV_76B2&SUBSYS_103C3643

    device instance id=

    HDAUDIO\FUNC_01&VEN_111D&DEV_76B2&SUBSYS_103C3643&REV_1003\4&1AFEFC9B&0&0001

    sooo,,,what ur solution sirrr???
    my sound doesnt workk:(

    ReplyDelete
  12. Make sure you install MS-UAA:
    KB888111 : Download

    For:
    HDAUDIO\FUNC_01&VEN_111D&DEV_76B2&SUBSYS_103C3643&REV_1003\4&1AFEFC9B&0&0001
    it is ATI HDMI audi device R2.18:
    http://tinyurl.com/2flb6p

    and then,
    for your audio isntall this driver:
    ftp://ftp.us.dell.com/audio/IDT_92HDXXX-HD-Audio_A06_R213367.exe
    its for dell but i match your hardware, if direct install fail, do manual install.

    The other one is MODEM;
    ftp://ftp.hp.com/pub/softpaq/sp39501-40000/sp39689.exe

    ReplyDelete
  13. could you plz tell me how to install windows xp in cq 40 tu301.

    ReplyDelete
  14. my laptop model is compaq presario cq40-336tu winxp sp3. i followed the instruction given above, it worked but when i restart the audio is gone. plss help me

    ReplyDelete
  15. Sir in Device manager i dont have audio with yello color please help..
    Same Product here and I use Windows XP

    ReplyDelete
  16. ihaving compaq hp notebook of model no. v 6307tu but i not getting proper driver for sound installation after formating my hdd i having problem pls suggest driver which will suitable for it

    ReplyDelete
  17. hello sir, i hav compaq presario cq40 317 tu, plz suggest me how to install windows xp with audio driver in it.....

    ReplyDelete
  18. Thanks for your help, so my laptop friends can function normally

    ReplyDelete
  19. NOT working...
    After I have completed the last step, it says that its not digitally signed and that it has denied to install the driver.

    How can I fix this?

    ReplyDelete
  20. oh i tried fixing it my self and now the problem is that it says that the device cannot start.

    how can that be solved?

    ReplyDelete
  21. by the way it says error code 10 , if that helps

    ReplyDelete
  22. Hi there, if it mention not digitally signed, just ignore the complaint,proceed with installation. by the way what laptop model did you use? and windows XP service pack 2 SP2/SP3?

    Another way is by getting the audio harware ID and post it here. You can refer my tutorial here how to get the HARDWARE ID for your audio:
    http://laptop-driver.blogspot.com/2009/12/how-to-check-hardware-id.html

    ReplyDelete
  23. hello...
    can you help me...
    my model laptop is presario cq40-337TU
    my os is win 7 and I want to change it to win XP

    what should i do??

    ReplyDelete
  24. Sir, i ALSO HAS PROBLEM WITH MY SOUND.. SUDDENLY THE SOUND IS NOT COME. IN THE DEVICE MANAGER THERE ARE 2 "IDT HIGH DEFINITION AUDIO CODEC" 1 working properly and the other has yellow exclamation mark.
    I already try re-install and doesn't work. I used Compaq Presario CQ40 - 324TU Windows XP SP2..


    this is for the exclamation mark device:
    Device id
    HDAUDIO\FUNC_01&VEN_8086&DEV_2802&SUBSYS_80860101&REV_1000\4&21E8FE0E&0&0201

    Hardware id :
    HDAUDIO\FUNC_01&VEN_8086&DEV_2802&SUBSYS_80860101&REV_1000
    HDAUDIO\FUNC_01&VEN_8086&DEV_2802&SUBSYS_80860101

    this for device that working properly:
    device id :
    HDAUDIO\FUNC_01&VEN_111D&DEV_76B2&SUBSYS_103C30F8&REV_1003\4&21E8FE0E&0&0001

    Hardware Id:
    HDAUDIO\FUNC_01&VEN_111D&DEV_76B2&SUBSYS_103C30F8&REV_1003
    HDAUDIO\FUNC_01&VEN_111D&DEV_76B2&SUBSYS_103C30F8

    oya for the info,
    a week ago i just update my vga driver. during a week everything fine and sound also fine.

    Please help me,
    khalifah_heru@yahoo.com

    ReplyDelete
  25. Dear Black-X
    I had downgraded my Compaq presario CQ40-327TU from vista to windows XP. After downgrading my pc's sound drivers are not working. I had tried everything but not able to find any solution. As far as ur said process is concern i downloaded and followed below process -
    (Windows XP SP3: Download (KB835221)

    Then restart, and install AUDIO Drivers:

    IDT - High Definition Audio Codecs (SP39671)
    Download (ftp))


    But i have not find Audio drive marked yellow (refer point 2 of your given step).

    can u suggest something which can work for me..... thanks

    ReplyDelete
  26. i have compaq desktop
    model no. cq3217in
    prod# BK260AACJ
    S/N INA01801KS
    i want install sound driver
    how can i do that?

    ReplyDelete
  27. sound driver for windows xp or 7?

    ReplyDelete
  28. can u tel me hw to install sound driver for compac presario 610

    ReplyDelete
  29. Black-x, can I copy this guide ?

    ReplyDelete
    Replies
    1. yup, just remember to give credits =)

      Delete
  30. Dear Sir,

    I have Compaq CQ40-425TU laptop.

    After installing Win 7 the audio is not heard. In device driver no icon mark is seen and under sound, audio & game heading devices are listed of high definition audio.

    I have reinstalled, updated from windows update but no change is state.

    kindly help.

    ReplyDelete
    Replies
    1. Hello there,
      This problem cause by Windows 7 installation bug or Windows 7 Version. You need to re-install windows, and it is better to use different windows 7 version and ISO.
      The bug could be -
      -Windows skip the important audio system file during installation.
      -Windows Mistakenly detect your audio devices as other device.

      Before re-installing Windows, try to restart the audio service first by:
      click start>on search column type "service">choose services> then windows will ask your permission.. click continue..>

      then search for audio service..> press a right-click..> choose restart> then audio service will do a restart.

      Delete